Re: [java-l] No hace el deploy correctamente GX

Sabrina, al final del documento en el link que enviaste dice lo siguiente:

Considerations

  • If you modify the Servlet Directory model property the web application automatic configuration is not done, you must complete the application configuration manually; generally this means:
    • configure the web.xml and context.xml files in the WEB-INF folder.


  •                SE REFIERE  A QUE DEBEMOS COPIAR LOS ARCHIVOS WEB.XML Y CONTEXT.XML A LA CARPETA WEB-INF ??? al ejecutar la aplicacion me tira el error:

      • The requested resource (/erpmx-xev1/servlet/hindex) is not available



    • copy all the libraries to the \WEB-INF\lib\ folder.
                        AL MOMENTO DE COMPILAR ME DA  EL SIGUIENTE ERROR:

                        cannot find symbol
                        symbol  : variable n1
                        location: class peliminoproductos
                            if ( GXutil.strcmp(t_a(23,A2EmpId,n1), A2EmpId) == 0 )

        NO ESTA ENCONTRANDO LA CLASE GXUTIL ??? DONDE DEBERIA BUSCARLA ??

    Estoy cambiando de compu y encontrandome con estos problemas.

    Aclaro que no estoy haciendo deployment, le descomente el invoker en el web.xml ... en la compu anterior funciona correctamente, la nueva no quiere.

Gracias desde ya
Camilo

                       



El 5/31/2010 9:55 AM, Sabrina Juarez escribió:

Hola

 

Cuando se crea un modelo java se crea de manera automática la webapp en el directorio del Tomcat – GX detecta la instalación del mismo y la instalación del JRE.:

http://wiki.gxtechnical.com/commwiki/servlet/hwiki?Creating+a+Java+model+with+GeneXus+X+is+very+simple+and+easy,

 

 

Tenemos detectado y reportado un problema – que estamos evaluando la solución – cuando el ambiente es de 64 bits:

SAC #28180 Propiedades por defecto dependientes de de java y apache tomcat no son inicializadas en versiones 64bits

 

Por el momento la solución, específicamente en este caso de tener un ambiente de 64 bits es armar el war deployment manualmente y luego asignar las rutas correspondientes a las propiedades servlet directory y static content directory seen from client.

 

Saludos

Sabrina.

 

 

From: Leandro Minatel [mailto:leandrominatel@gmail.com]
Sent: Lunes, 31 de Mayo de 2010 11:44 a.m.
To: java-l@gxtech.com.uy
Subject: Re: [java-l] No hace el deploy correctamente GX

 

Hola Juan Manuel,

algo que he notado es que el u2 de la Ev1 no hace todo "automagicamente". Antes, creaba la estructura de directorios, el web.xml, copiaba las librerias y (creo) creaba el manifest. A partir del ultimo upgrade, cuando creo un environment nuevo, tengo que hacer todo yo, a mano.

Lo extraño en tu caso es que ni siquiera te crea los archivos class en la carpeta WEB-INF/classes, quizas falte configurar las rutas en las propiedades del environment.

Slds


2010/5/31 Juan Manuel <juanma.azpiroz@gmail.com>

Eso que tu me decis los he comprobado en otros equipos y si, es corrrecto gx se encarga.

Pero en este caso no lo hace, y no entiendo por que.

Fue instalado Tomcat, luego gx

Creo la Kb, generador Java

creo una trn.

Reorganizo

Compilo

Run

Y nada :(

Reviso el directorio de webapps de Tomcat y veo que gx no genero los archivos necesarios

como tampoco copio los jars necesarios.

gracias,

El 31 de mayo de 2010 11:06, Gabriel goyo <gabriel_mcv@yahoo.com.mx> escribió:

 

Estiado amigo:

 

El Java Deployment Wizard de GX 10 EV1 si genera todos los archivos que tu dices... e incluso te crea las librerias necesarias... sin embargo eso debe ser definido por ti en el mismo wizard.. Seria conveniente que envies los pasos que estas realizando en el Deployment Wizard para saber exactamente que es lo que te falta hacer, ya que yo genero los archivos .war en java para el mismo servidor e incluso para glassfish y me genera todo de forma correcta.

 

Saludos

Gabriel Error! Filename not specified.

Ing. Gabriel Goyo C.

Ingeniero de Sistemas 



--- El vie 28-may-10, Juan Manuel <juanma.azpiroz@gmail.com> escribió:


De: Juan Manuel <juanma.azpiroz@gmail.com>
Asunto: [java-l] No hace el deploy correctamente GX
A: java-l@gxtech.com.uy
Fecha: viernes, 28 de mayo de 2010, 7:16

 

Estimados:

 

Escenario: EV1, Tomcat 5.5, generador Java.

 

Tengo el siiguiente problema, gx en EV1 no me genera ni el archivo web.xml, context.xml ni tampoco me copia las librerias necesarias

a la carpeta lib de mi aplicacion, en webapps de TOmcat.

Copiando el web.xml y las librerias para los lugares correctos, lo hacemos funcionar, pero esto deberia ser automático por gx no??

por otra parte haciendo esto, si realizo cambios y luego doy F5 los cambios no los impacta, si lo hago con Rebuild All, si los cambios son impactados

Todo lo demas lo genera bien, estructura de carpetas y demas.
desde ya muchas gracias,
--
A/S Juan Manuel Azpiroz
San José - Uruguay


Por favor tenga en cuenta el Medio Ambiente, preservarlo depende de todos


 




--
A/S Juan Manuel Azpiroz
San José - Uruguay


Por favor tenga en cuenta el Medio Ambiente, preservarlo depende de todos




--
I get paid to support Windows, I use Linux to get work done.


2 Response to "Re: [java-l] No hace el deploy correctamente GX"

  1. Felipexto says:
    4 de julio de 2014, 5:59

    Instala nuevamente JDK Java y el ApacheTomcat

  2. Felipexto says:
    4 de julio de 2014, 6:00

    Si este es el escenario:
    Tengo el siiguiente problema, gx en EV1 no me genera ni el archivo web.xml, context.xml ni tampoco me copia las librerias necesarias

    A mi me funciono:
    1. Desintalar ApacheTomcat
    2. Desintalar JDK Java
    3. Configurar las variables de entrono Java en JAVA_HOME y Path
    4. Instalar JDK Java
    5. Instalar ApacheTomcat
    6. Cuando se crea una nueva KB en las propiedades del generador Java deben aparecer las rutas a JDK Java, y al apache Tomcat, esta es la prueba de que funcionara.

    Saludos,
    Felipe

Publicar un comentario en la entrada